• Предмет: Информатика
  • Автор: InTheDagger
  • Вопрос задан 4 года назад

Записать решение задачи в виде таблицы. Имеется два пустых сосуда объемом 11 и 2 литра. Надо получить 1 литр воды в любом из сосудов. Используйте цикл "N раз"​


Ziorar: В Кумире надо? Тогда, может так:

использовать Водолей
алг
нач
наполни A
нц 5 раз
перелей из A в B
вылей B
кц
кон
Ziorar: А в таблице заполняете, сколько литров воды есть в сосудах после каждой операции по переливанию её:
__A__ __B__ __№шага
__0 __ __0__ __0 (до начала)
__11 __ __0__ __1 (наполнили сосуд A)
__9 __ __2__ __2 (перелили в сосуд B)
__9 __ __0__ __3 (вылили из сосуда B)
__7 __ __2__ __4 (перелили в сосуд B)
... и так далее, все 5 циклов (до тех пор, пока в A не останется 1 литр)

Ответы

Ответ дал: poli123i4
1

__A__ __B__ __№шага

__0 __ __0__ __0 (до начала)

__11 __ __0__ __1 (наполнили сосуд A)

__9 __ __2__ __2 (перелили в сосуд B)

__9 __ __0__ __3 (вылили из сосуда B)

__7 __ __2__ __4 (перелили в сосуд B)

... и так далее, все 5 циклов (до тех пор, пока в A не останется 1 литр)

Похожие вопросы